polidog lab

Top About Rss
2011年02月28日

CentOS5.4にmemcachedを入れる。

開発環境のCentOSにmemcachedを入れようとおもった、ちょっとトラぶったののでメモ。
まずは普通にyumでインストール

$ yum install memcached

そしてエラーになった・・・

= 1.33 is needed by package perl-AnyEvent-5.240-1.el5.rf.noarch (dag)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

どうやらperl-Net-SSLeayがないようだったので、やっぱりyumでいれてみた

yum install perl-Net-SSLeay

こっちはしっかりインストールできたので、さいどyumでいれる。
そしてやっぱりエラー。。。
どうやら「 perl(Net::SSLeay) >= 1.33」ということでバージョンが古かったみたい(´・ω・`)
rpmforgeからいれればいいんじゃね?ってことで入れてみた

yum install --enablerepo=rpmforge perl-Net-SSLeay

あれ、バージョン1.3.0じゃん。。。しかたないrpmで突っ込むか。

yum remove perl-Net-SSLeay

wget http://packages.sw.be/perl-Net-SSLeay/perl-Net-SSLeay-1.36-1.el5.rfx.i386.rpm
rpm -i perl-Net-SSLeay-1.36-1.el5.rfx.i386.rpm

ふう無事にはいった。
ということでPECLでmemachedいれるか。

pecl install memcached

checking for libmemcached location... configure: error: memcached support requires libmemcached. Use --with-libmemcached-dir=<dir>
  to specify the prefix where libmemcached headers and library are located
  ERROR: `/var/tmp/memcached/configure' failed

yum install -y memcached-devel

yum install php-pecl-memcached

php-pecl-memcached-1.0.0-1.el5.i386 from epel has depsolving problems
--> Missing Dependency: php-zend-abi = 20050922 is needed by package php-pecl-memcached-1.0.0-1.el5.i386 (epel)
Error: Missing Dependency: php-zend-abi = 20050922 is needed by package php-pecl-memcached-1.0.0-1.el5.i386 (epel)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
                      package-cleanup --dupes

yum install --enablerepo=remi  php-pecl-memcached
comments powered by Disqus