Last.fm RPSの不具合について

April 15, 2010,
tags: php wordpress


このエントリーをはてなブックマークに追加

WordPressも最新版にアップデートしたらLast.fm RPSが動かなくなりました。
エラーメッセージが表示されており、以下のようになっていました。

Parse error: syntax error, unexpected '}' in /var/www/public_html/wp-content/plugins/lastfm-rps/lastfm.php on line 450

最初はWPのバージョンを上げたから動作しなくなったのかと思いましたが、どうやらちがう。
てかsyntax errorって・・・おいおい・・・とか思っていたのですが、どんなにソースみても、syntax errorが見つからない。

とふとコードの一番最初をみると

<?
/*
 * Plugin Name: Last.fm RPS

みたいな感じで始まっている・・・・
これじゃ動かないわけです。
php.iniで「short_open_tag = Off」にしてるんだから・・・。
ということで、一行目を以下のように修正しました。

<?php
/*
 * Plugin Name: Last.fm RPS

てか、WPアップデートする前に動いていたのが不思議だ・・・。

comments powered by Disqus